Friday, August 5, 2016

Native VLAN mismatch Error on Access Port

Cisco switches always have VLAN 1 as the default VLAN, which is needed for many protocol communication between switches like spanning-tree protocol for instance. Unfortunately you can't change or even delete the default VLAN, it is mandatory.
The native VLAN is the only VLAN which is not tagged in a trunk, in other words, native VLAN frames are transmitted unchanged.
Per default the native VLAN is VLAN 1 but you can change that.



#show interface Fa0/8 trunk
Port        Mode             Encapsulation  Status        Native vlan
Fa0/8       on               802.1q         other         1

To change it use the following command: switchport trunk native vlan <vlan number>
(config-if)#switchport trunk native vlan 2
(config-if)#do show interface f0/8 trunk
Port        Mode             Encapsulation  Status        Native vlan
Fa0/8       on               802.1q         other         2
The default VLAN is still VLAN 1.
#show vlan id 1
VLAN Name Status    Ports
---- -------------------------------- --------- -------------------------------
1    default active    Fa0/8, Gi0/1


I am having two switches connected by access port but with two different vlan at both end. On both ends I got following Native VLAN mismatch discovered errors.

SW1# sh log
Aug 5 15:16:35.286: %CDP-4-
NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/39 (14), with SW2 GigabitEthernet0/1/0 (2). Aug 5 15:17:33.992: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/39 (14), with SW2 GigabitEthernet0/1/0 (2). Aug 5 15:18:32.149: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/39 (14), with SW2 GigabitEthernet0/1/0 (2). Aug 5 15:19:28.217: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/39 (14), with SW2 GigabitEthernet0/1/0 (2). Aug 5 15:20:24.622: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/39 (14), with SW2 GigabitEthernet0/1/0 (2). Aug 5 15:21:17.736: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/39 (14), with SW2 GigabitEthernet0/1/0 (2). Aug 5 15:22:10.554: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/39 (14), with SW2 GigabitEthernet0/1/0 (2). Aug 5 15:23:01.778: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/39 (14), with SW2 GigabitEthernet0/1/0 (2). Aug 5 15:24:00.581: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/39 (14), with SW2 GigabitEthernet0/1/0 (2). SW1#



SW1#show cdp nei det | b SW2
Device ID: SW2
Entry address(es): 
  IP address: 172.18.14.11
Platform: cisco ISR4331/K9,  Capabilities: Router Switch IGMP 
Interface: GigabitEthernet1/39,  Port ID (outgoing port): GigabitEthernet0/1/0
Holdtime : 151 sec

Version :
Cisco IOS Software, ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.6(1)S1, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2016 by Cisco Systems, Inc.
Compiled Wed 09-Mar-16 18:32 by mcpre

advertisement version: 2
VTP Management Domain: ''
Native VLAN: 2 (Mismatch)
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 1, Power available: 0, Power management level: -1
Management address(es): 
  IP address: 172.18.14.11
SW1#


The Configuration on the ports at both ends:

SW1(config-if)#do sh run int g1/39
Building configuration...

Current configuration : 133 bytes
!
interface GigabitEthernet1/39
 description SW2 G0/1/0
 switchport access vlan 14
 switchport mode access
end
SW1#



SW2#sh run int g0/1/0

interface GigabitEthernet0/1/0
 description MS-Network-MGMT
 switchport access vlan 2
 spanning-tree portfast 

SW2#show cdp nei det
... Device ID: SW1 Entry address(es): IP address: 172.18.14.3 Platform: cisco WS-C4510R+E, Capabilities: Router Switch IGMP Interface: GigabitEthernet0/1/0, Port ID (outgoing port): GigabitEthernet1/39 Holdtime : 121 sec
SW2#


In circumstances like this, where you are sure the mismatch is not a real problem, you may consider to disable cdp for those interfaces to shut up those noise information.

SW2#show run int g1/39
Building configuration...

Current configuration : 148 bytes
!
interface GigabitEthernet1/39
 description SW2 G0/1/0
 switchport access vlan 14
 switchport mode access
 no cdp enable
end
SW2#










No comments:

Post a Comment